MPLS Lab 008 CE-PE Routing Using Redistribute EIGRP

Image requirements:
VIRL: IOSv 15.7
EVE-NG: Cisco vIOS Router vios-15.6
GNS3: vios-adventerprisek9-m.vmdk.SPA.156-2.T



Description:
EIGPR will be routing protocol of the choice for new service with another customer, this contract will be including the installation of L3 MPLS VPN services at the three remote locations, client expecting completion of the work as soon as possible, bring your excellent skills, obtained from the previous experience to this project, implement the configuration of VRF, CE-PE routing using EIGRP, and MP-BGP protocol.



Topology:


Download Lab: EVE-NG | GNS3




Scenario:
Another contract has been signed, this client needs to use EIGRP as the mechanism to exchange routes between the ISP and its private networks, there are three locations needed to be interconnected over the MPLS cloud, the same standard procedure has to be implemented, configuring the VRF, exchange routes with the client, redistribute into BGP VPNv4 tables and finally verify the proper operation of the service.



Lab tasks:
1. Configure VRF CE1 on all PE routers connected to the customer's locations.
2. Assign VRF CE1 to the G0/3 interfaces on the PE routers.
3. Exchange prefixes using the EIGRP routing protocol.
4. Redistribute routes between the BGP VPNv4 and EIGRP routing structures.
5. Verify that customers' sites able to communicate with each other.



Lab procedure:

Task1: Implement VRFs named CE1 at PE2, PE3, PE4.
Configuration:
PE2(config)#vrf definition CE1
PE2(config-vrf)#rd 1800:1800
PE2(config-vrf)#address-family ipv4 unicast
PE2(config-vrf-af)#route-target export 1800:1800
PE2(config-vrf-af)#route-target import 1800:1800
PE2(config-vrf-af)# exit
Complete the same configuration on the remaining LSRs.

Verification:
PE2# show vrf brief
PE2# show vrf detail CE1




Task2: Assign VRF CE1 to the G0/3 interfaces on the PE routers.
Configuration:
PE2(config)#interface g0/3
PE2(config-if)#vrf forwarding CE1
PE2(config-if)#ip address 10.150.0.2 255.255.255.252
PE2(config-if)#exit


Verification:
PE2#show ip route vrf CE1
Routing Table: CE1
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.150.0.0/30 is directly connected, GigabitEthernet0/3
L 10.150.0.2/32 is directly connected, GigabitEthernet0/3




Task3: Exchange prefixes using the named EIGRP routing protocol. 
Configuring nodes PE2 and CE1-A:
PE2(config)#router eigrp EIGRP_VRF_CE1
PE2(config-router)#address-family ipv4 unicast vrf CE1 autonomous-system 10
PE2(config-router-af)#network 10.0.0.0
PE2(config-router-af)#end
CE1-A(config)#router eigrp 10
CE1-A(config-router)#network 10.0.0.0
CE1-A(config-router)# end
Complete the same configuration on the remaining LSRs and CE routers.


Verification:
PE2#show ip route vrf CE1 eigrp
PE2#show ip protocols
PE2#show ip eigrp vrf CE1 neighbors
PE2#show ip eigrp vrf CE1 topology




Task4: Redistribute routes between the BGP VPNv4 and EIGRP routing structures.
Configuring node PE2:
PE2(config)#router bgp 64500
PE2(config-router)#address-family ipv4 unicast vrf CE1
PE2(config-router-af)#redistribute eigrp 10
PE2(config-router-af)# end
PE2(config)#router eigrp EIGRP_VRF_CE1
PE2(config-router)#address-family ipv4 unicast vrf CE1 autonomous-system 10
PE2(config-router-af)#topology base
PE2(config-router-af-topology)#default-metric 50000 100 255 1 1500
PE2(config-router-af-topology)#redistribute bgp 64500
PE2(config-router-af-topology)#end

Complete the same configuration on the remaining LSRs.


Verification:
PE2#show bgp vpnv4 unicast vrf CE1
PE2#show ip route vrf CE1




Task5: Verify that customers' sites able to communicate with each other.
Check the BGP VPNv4 table on the PE routers and as well CE1 VRF routing tables:
PE2# show bgp vpnv4 unicast vrf CE1
PE2# show ip route vrf CE1

Check the EIGRP routing table and ping remote LAN networks' IP addresses from CE routers:
CE1-A#show ip route eigrp
CE1-A#ping 10.160.0.1 source lo0
CE1-A#ping 10.165.0.1 source lo0



Additional task:
At the HQ location where router CE1-A resides the network 10.155.0.0/24 is serving to the main floor employees, it has been decided that the confidential information of financial department should not share the same subnet with the rest of the staff, that is why you need to configure the additional subnet for this matter to be resolved, use 10.155.1.0/24 subnet. Configure the new loopback 1 interface with an appropriate IP setting, then verify if the network has been propagated to the other CE locations. 



Summary:
As you can see from the second deployment of a dynamic routing protocol that configurations are getting more complex but on the other hand, the efficiency becomes better, and when new prefixes were introduced to the customer's topology, the propagation of these routes is instantaneous, showing us that convergence is very fast, which is important to such complex network design.

Comments

Popular Posts