Frame Relay Switch Method 1
Previous Next
Download Lab: GNS3
Prerequisites:
Cisco Image (c7200-a3jk9s-mz.124-25g.image)
If you do not have this image then just use any image you possess which supports frame-relay and serial interfaces.
Create topology as shown in this lab and then proceed to configure routers.
Introduction:
This lab teaches CCNA students how to configure frame-relay switch out of the router, using frame-relay route command.
Topology:
Scenario:
Two routers in the middle of the topology are frame-relay switches connected to the clients, you need to create a bidirectional path across frame-relay cloud between two interfaces facing customer locations. DLCI 100 will be used for client sites and DLCI 50 on the link between frame-relay switches as shown in the topology.
Lab procedure:
Step1: Configure customer sites.
R4(config)#
interface Serial1/0
ip address 10.0.0.1 255.255.255.252
encapsulation frame-relay
frame-relay intf-type dte
frame-relay map ip 10.0.0.2 100 broadcast
R5(config)#
interface Serial1/0
ip address 10.0.0.2 255.255.255.252
encapsulation frame-relay
frame-relay intf-type dte
frame-relay map ip 10.0.0.1 100 broadcast
Step2: Enable frame-relay switching.
FRSW1(config)# frame-relay switching
!
FRSW2(config)# frame-relay switching
Step3: Configure the link between frame-relay switches.
FRSW1(config)#
interface Serial1/0
encapsulation frame-relay
clock rate 8064000
frame-relay intf-type nni
no shutdown
FRSW2(config)#
interface Serial1/0
encapsulation frame-relay
clock rate 8064000
frame-relay intf-type nni
no shutdown
Step4: Configure interfaces facing customer's routers.
FRSW1(config)#
interface Serial1/1
encapsulation frame-relay
clock rate 8064000
frame-relay intf-type dce
no shutdown
FRSW2(config)#
interface Serial1/1
encapsulation frame-relay
clock rate 8064000
frame-relay intf-type dce
no shutdown
Step5: Using the frame-relay route command create two logical paths, one to direct traffic from the customer on to the link between FR switches and the second path to accept frames from the link and route them to the clients.
FRSW1(config)#
interface Serial1/1
frame-relay route 100 interface Serial1/0 50
!
interface Serial1/0
frame-relay route 50 interface Serial1/1 100
Repeat this process on the second switch:
FRSW2(config)#
interface Serial1/1
frame-relay route 100 interface Serial1/0 50
!
interface Serial1/0
frame-relay route 50 interface Serial1/1 100
Step6: Verify frame-relay routes.
FRSW1#show frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial1/0 50 Serial1/1 100 active
Serial1/1 100 Serial1/0 50 active
FRSW2#show frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial1/0 50 Serial1/1 100 active
Serial1/1 100 Serial1/0 50 active
Step7: Verify frame-relay configurations on the client sites:
R4#show frame-relay map
Serial1/0 (up): ip 10.0.0.2 dlci 100(0x64,0x1840), static,
broadcast,
CISCO, status defined, active
R4#ping 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/40/48 ms
Download Lab: GNS3
Prerequisites:
Cisco Image (c7200-a3jk9s-mz.124-25g.image)
If you do not have this image then just use any image you possess which supports frame-relay and serial interfaces.
Create topology as shown in this lab and then proceed to configure routers.
Introduction:
This lab teaches CCNA students how to configure frame-relay switch out of the router, using frame-relay route command.
Topology:
Scenario:
Two routers in the middle of the topology are frame-relay switches connected to the clients, you need to create a bidirectional path across frame-relay cloud between two interfaces facing customer locations. DLCI 100 will be used for client sites and DLCI 50 on the link between frame-relay switches as shown in the topology.
Lab procedure:
Step1: Configure customer sites.
R4(config)#
interface Serial1/0
ip address 10.0.0.1 255.255.255.252
encapsulation frame-relay
frame-relay intf-type dte
frame-relay map ip 10.0.0.2 100 broadcast
R5(config)#
interface Serial1/0
ip address 10.0.0.2 255.255.255.252
encapsulation frame-relay
frame-relay intf-type dte
frame-relay map ip 10.0.0.1 100 broadcast
Step2: Enable frame-relay switching.
FRSW1(config)# frame-relay switching
!
FRSW2(config)# frame-relay switching
Step3: Configure the link between frame-relay switches.
FRSW1(config)#
interface Serial1/0
encapsulation frame-relay
clock rate 8064000
frame-relay intf-type nni
no shutdown
FRSW2(config)#
interface Serial1/0
encapsulation frame-relay
clock rate 8064000
frame-relay intf-type nni
no shutdown
Step4: Configure interfaces facing customer's routers.
FRSW1(config)#
interface Serial1/1
encapsulation frame-relay
clock rate 8064000
frame-relay intf-type dce
no shutdown
FRSW2(config)#
interface Serial1/1
encapsulation frame-relay
clock rate 8064000
frame-relay intf-type dce
no shutdown
Step5: Using the frame-relay route command create two logical paths, one to direct traffic from the customer on to the link between FR switches and the second path to accept frames from the link and route them to the clients.
FRSW1(config)#
interface Serial1/1
frame-relay route 100 interface Serial1/0 50
!
interface Serial1/0
frame-relay route 50 interface Serial1/1 100
Repeat this process on the second switch:
FRSW2(config)#
interface Serial1/1
frame-relay route 100 interface Serial1/0 50
!
interface Serial1/0
frame-relay route 50 interface Serial1/1 100
Step6: Verify frame-relay routes.
FRSW1#show frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial1/0 50 Serial1/1 100 active
Serial1/1 100 Serial1/0 50 active
FRSW2#show frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial1/0 50 Serial1/1 100 active
Serial1/1 100 Serial1/0 50 active
Step7: Verify frame-relay configurations on the client sites:
R4#show frame-relay map
Serial1/0 (up): ip 10.0.0.2 dlci 100(0x64,0x1840), static,
broadcast,
CISCO, status defined, active
R4#ping 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/40/48 ms
Comments
Post a Comment